Each language has their own conventions in the style guides for how they prefer variables and functions to be named.
For example,
- Python uses
snake_case
- C and C++ also generally use snake case, but have specific conventions for particular types of variables
- Java, JavaScript, and C# use
camelCase
(like your examples) - Pascal, Dart, and a few others use
UpperCamelCase
that’s like camel case, but the first letter is also capitalized
And then some organizations like to override those and institute their own conventions. I generally think the latter is a bad idea, since it breaks with accepted industry standards for a given language. Even for a personal project you know that no one else will touch, I think it’s good to follow the langues guides.
I generally wouldn’t make a compound word all lowercase. strikethroughoffset
is much more difficult to read, IMO. If you’re going that route, then you should at least snake case it: strike_through_offset
. But again, a lot of this is going to depend on your situation.
It’s not really a “get good” issue so much as it’s just an annoying part of the industry one has to navigate.
The Mythical Man-Month is a classic